Alchemist Failed to connect error

Hi I’ve just taken delivery of an Alchemist. I have updated firmware to latest, setup account on website, connected alchemist via USB to my Mac running 10.14.6. I have logged into site using Chrome browser and midi connection allowed in settings but every time I click on connect to device I get failed to connect error?

Please help


Hi there,

was it working before the firmware update?
If you open Audio and MIDI Settings, does the device show up as a MIDI connection?

Hi thanks for response

No it was not working prior to Firmware update also it arrived without any patches stored in it contrary to what was stated in getting started sheet. Yes it shows up as midi device and I updated firmware using Sysex on the Mac I’m having issue with. I have since tried it on my MacBook which is running the same version of OS and Chrome and it works fine all but it being glitchy with some patches. I’m baffled to why it does not work on iMac??


Connection issue solved! The device was showing up as OWL-BOOT in midi devices even though was not started up in boot mode. I deleted the device in midi devices and reconnected and now shows up as OWL-MIDI and now connects via Patch page in chrome. The only other issue is that when 4 or more patches are saved to device switching patches on the device It gets confused and will not select the fourth patch and has stopped functioning until I reset or wipe memory?