Audio issues during first Owl Modular test

Hi fam

I purchased the OWL mainly to prototype some of my audio development on an ARM Cortex. So, I recently wanted to give the pre-installed patches a try to see if everything works as expected. I connected an output from my audio interface to the left input of the OWL and ran the OWL’s left output back into one of my interface’s inputs.
Then I just ran a basic drum loop in a DAW and routed the audio to the OWL. The only output signal I was able to get out of the OWL was distortion and noise though. I assume I’m just missing something here. I’m no Eurorack expert so maybe I’m getting some power or signal levels wrong here. Any help would be appreciated on this :).

P.S.: The module seems to boot OK, the green LED is glowing. I also tried switching banks and patches and the module seemed to be loading them, guessing by the red fast blinking LED. I ran a quick attempt at trying to install the Mac OWL Control binaries but they won’t run on my Mac. I’ll try compiling OWL control from source to see if I can get it to run that way next.


UPDATE: I patched some Eurorack level signals through the owl modular yesterday and it worked OK. I then tried sending some line level from my phone through the owl and it also worked. I have no idea why the interface outs wouldn’t work, Ill get anther chance to test with the interface tonight. I’ve organized an expert sleepers interface module for the future, so once i receive that these issues shouldn’t be a problem anymore.

Hiya, sorry for not replying sooner - is it all working for you now?

Hi Mars,

Thanks for the reply and now I have to apologize for the late response ;). Yeah, so it worked fine when I sent line level into the OWL again later. I have to retry with the specific IF that i used originally, don’t really know what could have gone wrong there. I’ll update the thread as soon as i get a chance to re-run a test with that IF.

Cheers and Merry Christmas!

1 Like

Hi Mars,

Some updates…

So, I’ve got some FX that id like to showcase on the OWL but I’m still experiencing some audio quality issues. Before i port some of my patches to the owl (Im planning on using pd/c++/faust) I ran a quick test patch based on the youtube tutorial pd tone generator (OWL Pure Data Tutorial 1: Tone Generator). I only used two OSCs instead of three. Upload and compilation in my patches worked and I was able to connect to my OWL. The output says I am connected to “OWL Modular v12” if that helps. The patch runs fine in the browser but when I run it on the OWL and direct monitor the output through my sound card theres very audible artifacts. If i listen closely to some other FX patches that use audio in (e.g phaser, wah-wah) I can also notice these artifacts but they are a lot more subtle (e.g. if i crank up the feedback a bit and then stop audio in, i can here clicks in the feedback loop).

When running the test patch this is the load stat output: CPU: 9% Memory: 6520

Maybe you have an idea what could still be going wrong? Do i need a FW update or something similar or might this be related to something different?

Thanks for your help!

UPDATE: It seem i can reproduce artifacts easily with other FX. E.g just by connecting my headphones to an output and then loading the jotreverb e.g. Turning the D knob will produce different amounts of artifacts. I am not running any audio through the owl for this test.