CoreMIDI error when loading/saving patches to Lich from terminal

Hi!

I’m trying to “make load” from a terminal in macOS Monterey to push a patch into Lich, but I keep getting a mysterious CoreMIDI error 387 for which I’m unable to find info online:

Building patch <...>
Sending patch <...> to OWL-* to load
CoreMIDI error: 387 - ffffffce
MIDI device not available: OWL-*
make: *** [load] Error 255

I’ve also tried using the FirmwareSender with the same result.

I don’t have any problem when using the browser, though.

Any idea of what could be causing it?

So does your OS see the MIDI device? I.e. you should get something like “OWL-Lich” among the output of FirmwareSender -l command. I wonder if it could be blocked when the browser accesses it on Mac, maybe that’s something to try to avoid.

Yeah, it’s reported as device #1 “OWL-LICH”:

MIDI input devices:
0: IAC Driver Bus 1
1: OWL-LICH
MIDI output devices:
0: IAC Driver Bus 1
1: OWL-LICH

I thought about the device potentially being locked by the browser and already tried with Chrome closed. I’ll try again later when the laptop just booted and nothing else is opened.

Ok, I’ve also tried after a fresh reboot, going directly into VSCode’s terminal, both this commands returns with a 387 CoreMIDI error:

make clean; make PLATFORM=OWL3 PATCHNAME=<...> load

Tools/FirmwareSender -in ./Build/patch.bin -out "OWL-LICH" -store 1

Don’t really know what’s happening here…