Error 0x80 Size mismatch calibrating the module Please, help

I have updated to Lich v22.5.0 Firmware: Lich v22.5.0

Calibrating the module when clicking on Store Settings I receive this error: *

  • Preset 0:
  • Sending data 6971 bytes
  • Preset 0: Calibration
  • Error 0x80 Size mismatch

I wonder if someone were so kind to point me in the right direction.
Thanks for reading!

I wonder if it would work if you try saving calibration settings a few times, it sounds like it might be just some error in your USB setup. Could be both software (multiple open tabs sending data to OWL or some other utility using the same MIDI device) or hardware (bad cable or USB port).

Please let me know if this error happens consistently.

Thanks a lot! Will try as you say

I had this same thing happen when trying to calibrate my Lich with a new OWL mk3 board and clicking Store Settings a second time appears to have fixed it. I got the message “Resource identical” up top and running the calibration test worked as expected.