Faust 2.54.9 creates broken patches?

Hey everyone,

I’m trying to confirm whether this is user error on my part, or if very recent versions of Faust don’t work with OwlProgram for creating patches for the Witch.

I’ve successfully been using a machine running Ubuntu 20.04 to compile and load Faust and C++ patches to my Witch. The version of Faust is 2.20.2.

However, I wanted to use libraries like quantizers.lib, which requires a more recent version of Faust.

So, I installed the following tools on a fresh installation of Ubuntu 23.05 on a second machine:

  • Faust (version 2.54.9), installed using apt
  • OwlProgram (along with FirmwareSender and emcc), installed per the README

Then I tried compiling and loading individual examples from https://www.openwarelab.org/Faust/:

The first example (the noise patch) works. The second example (parameter input) does not, nor does the parameter output example. The parameter input example produces no audio; the parameter output does not produce CV.

I didn’t try every example on that page, but I did confirm that the MIDI example and the simple sequencer also do not work when loaded onto the Witch.

Compiling and loading C++ patches works fine.

I’d love to know if anyone can reproduce this behavior?

Thanks in advance!

You should probably use recent version of FAUST built from github. I think OwlProgram version may not work with that too, but I have a branch with some fixes that was tested recently and seems to work well.

Thank you, @antisvin - that worked!

1 Like