Firmware downgrade

To test I put the new 21.2.1 firmware on my Owl modular. It still works but maybe it’s not ready yet. You will be re-installing the old 1.4 firmware but I have noticed that owncontroll no longer works. How do I downgrade the firmware ???

You should be able to install old firmware the usual way with DFU, is there some problem with that?

OwlControl is deprecated in favour of the website.
Apart from that, what wasn’t working for you with the new firmware?

thanks Martin

I did not downgrade and I kept the new firmware. I was able to get the patch changed through program changes from the software (Ableton) and so I can access the patches remotely (if you can re-enable the ability to do this on the machine it would be great). The only thing I have to say is that the exp input doesn’t work anymore, push in / out I haven’t tried them. I also loaded the Befaco Lich patches and they work but only the four pots. Anyway thanks for updating the old Owl, we old customers appreciate these things.

1 Like

Done, we’ve magically re-enabled this on your device - see instruction [solved] Can't connect to Magus - #7 by antisvin

But there are only four pots on Lich, there is no expression input and parameter E is not controllable by CV. It does have 2 CV output on F&G.

Push button will certainly work and also it’s possible to control LEDs separately as button 1/2. Not sure about expression input, might be something that we’ve missed.

the selection of the patches you indicated works … thanks. If you can re-enable the exp input it would be the best.