Help. Problem with Witch. Invalid Sysex

I just got my Witch after playing with it a bit I got a invalid sysex system message. I tried to reset the synth and then reloaded the firmware and restored patches but I still get the Sysex Message and a Error 0x70 Preventing reset program from starting message. It still just get flashing lights. What can I do?

And no matter what I do I still get * Program Message: Invalid SysEx

  • Error: Error 0x70 Preventing reset program from starting

I also get Error 0x80 Init failed

Did you erase the flash storage before restoring patches?

Yeah, I went through the whole process a couple of times but it always goes back to “Invalid SysEx” then if I reset to “Error 0x70 Preventing reset program from starting” or “Error 0x80 Init failed”. I only used it for about an hour before it stopped working and I got the initial “Invalid SysEx”. Is there anything else I can do?

Which firmware version do you run?

Also, sorry to reiterate, but when you say that you went through the whole process - did you erase storage (i.e. on device) page or just wrote the same patches? Because you can’t erase storage using only UI on , overwriting old patches keeps their data just marks it as deleted. So corrupt patches can still cause problem even if they would be invisible.

Yeah, I went to erased it on the device page erased device then reset the device. Then I went to firmware page ([OpenWareLaboratory (OpenWareLaboratory) and followed the steps and updated it with Witch v22.5.rc4 which I found on a link on the page. Then I went to the page and tried to re-load the content where I started to get those messages like “Invalid SysEx” or
“*Error: Error 0x70 Preventing reset program from starting”. The synth is unresponsive sometimes with the various combinations of error lights or just the F indicator slowly pulsing.

I just went through all the steps again and it seemed successful except I got one error message when restoring the files “* Error 0x80 Readback failed” but I’m still stuck with flashing error lights. I went back to the device page and reset the device and didn’t get an error message but the Witch is still flashing and unresponsive. On the OpenWare page it just notes the * Error: Error 0x80 Readback failed message and the * Firmware version: Witch v22.5.rc4.

Then I tried to reset it on the device page and get Error 0x70 Preventing reset program from starting.

Ah, someone mentioned before that this firmware release candidate had issues on Witch. So you could try some older versions (and erasing flash storage after changing firmware is highly recommended).

The errors that you’ve mentioned seem to indicate problems with flash storage and I think it might be hardware related (i.e. faulty chip). So if downgrading firmware won’t help, you probably could arrange return/replacement with @Befaco

I think you’re right, seems like a hardware problem. I tried the older firmware, I even tried different cords and a different computer—same results! Thanks for your help. Seemed like a cool piece of gear.

Hi there!

So you tried with firmware version 22.2?

Please contact if this firmware is also causing issues!

Hey, I tried the firmware firmware version 22.2 and I’m immediately getting the Invalid Sysex message. I don’t think it is recoverable. I will contact support. Thanks.