How to recover Witch in OWL-BOOT mode after failed firmware upgrade

I tried to upgrade the firmware on my Witch using the following steps and then seemingly bricked it somehow during the process:

  1. Initially was recognized as a witch in the area

  2. Downloaded version 22.4.0 of Witch.syx from the GitHub OpenWare releases

  3. ERASED STORAGE from the Device Page first

  4. Visited the firmware page (OpenWareLaboratory) and followed the steps. After sending the firmware initially downloaded I never received a “Firmware upload complete” and the it basically froze.

  5. After power on and off, attempts at device reset, I keep getting all red lights on at start but a “OWL-BOOT” is still recognized on the midi in and out via usb, but the device is no long recognized as a Witch and I can’t load or store patches.

How do I fix this?

Hi @shakfu,
It looks like you’ve had some problem flashing the firmware at step 4 and now there’s no valid firmware to run. What you see is the bootloader mode and this is normal in such situation.

Most likely you can solve this by flashing the firmware again, make sure to use a good USB cable and ideally open just one browser window.

Hi @antisvin

Thanks very much for your help.

I tried again using the usb cable which came with the Witch and after a couple of attempts, it worked! :smiley:

Looked like the issue was caused by using a faulty cable. Well-diagnosed and solved!



1 Like