Lich as sound card on Linux - alsa erroring out, card detected as 1 in 1 out, doesnt work

Hi all, I am running firmware Lich v22.5.0 and connecting the lich via USB to a RPI 3 .

Alsa sees the device but as a 1 in 1 out card correctly. Selecting the card with jackd doesn’t seem to work at all. I think the issue is i am no running the jackd command with correct settings.

here is the command to select Lich as the main soundcard:
jackd -d alsa -d hw:OWLLICH -i 2 -o 2

creating alsa driver ... hw:OWLLICH|hw:OWLLICH|1024|2|48000|2|2|nomon|swmeter|-|32bit
configuring for 48000Hz, period = 1024 frames (21.3 ms), buffer = 2 periods
ALSA: final selected sample format for capture: 16bit little-endian
ALSA: use 2 periods for capture
ALSA: final selected sample format for playback: 16bit little-endian
ALSA: use 2 periods for playback

Alsa recommends a 2 in 2 out card setting. It defaults to 1024 frames and a 2 period buffer. Maybe that is not the correct setting?

Midi seems ok

What i expected was a 4 in 5 out soundcard though - is this exposable in some way?

It sends audio only, so must be stereo. If you want to experiment with raw ALSA devices something like this could be used:

The “correct” setting is something that works with your RPI and kernel combination, so you would have to experiment a bit to find something that works. It might require switching to realtime kernel to get decent latency. And you should absolutely experiment with period/buffer values.

I cant get the driver to even stick before i get into latency tweaking unfortunately.
is it just a guessing game for what will work?

maybe these errors help, forgot to include them earlier

ALSA: poll time out, polled for 3999082 usecs, Retrying with a recovery, retry cnt = 1
JackPosixProcessSync::LockedTimedWait error usec = 5000000 err = Connection timed out
Driver is not running
Cannot create new client

this is the jackd command i ran
jackd -d alsa -d hw:OWLLICH -i 2 -o 2 -p 128 -n 2 -r 48000 -S16_LE

and heres the initialization before the errors
Acquire audio card Audio4
creating alsa driver … hw:OWLLICH|hw:OWLLICH|128|2|48000|2|2|nomon|swmeter|-|16bit
configuring for 48000Hz, period = 128 frames (2.7 ms), buffer = 2 periods

also heres the arecord dump - hopefully its correctly formed

arecord -D hw:OWLLICH --dump-hw-params
Warning: Some sources (like microphones) may produce inaudible results
         with 8-bit sampling. Use '-f' argument to increase resolution
         e.g. '-f S16_LE'.
Recording WAVE 'stdin' : Unsigned 8 bit, Rate 8000 Hz, Mono
HW Params of device "hw:OWLLICH":
RATE: 48000
PERIOD_TIME: [1000 1000000]
PERIOD_SIZE: [48 48000]
PERIOD_BYTES: [192 192000]
PERIODS: [2 1024]
BUFFER_TIME: [2000 2000000]
BUFFER_SIZE: [96 96000]
BUFFER_BYTES: [384 384000]
arecord: set_params:1352: Sample format non available
Available formats:
- S16_LE

I just tested my v22.5.0 Lich on my laptop with pipewire and it shows up as the expected stereo i/o device (not sure why you expected 4:5 …) and it works great.

However I’m also not able to get jack2 to connect to it. Same timeout issue.

i assumed the cv in outs and gate out were exposed .

tried a bunch of different settings but no luck with getting jack to grab it. Pretty sure its running in realtime

my hifiberry hat inits correctly

JACK server starting in realtime mode with priority 10
self-connect-mode is "Don't restrict self connect requests"
Acquire audio card Audio3
creating alsa driver ... hw:3|hw:3|1024|2|48000|0|0|nomon|swmeter|-|32bit
ALSA: Cannot open PCM device alsa_pcm for capture. Falling back to playback-only mode
configuring for 48000Hz, period = 1024 frames (21.3 ms), buffer = 2 periods
ALSA: final selected sample format for playback: 32bit integer little-endian
ALSA: use 2 periods for playback

2 other “class compliant” cards also work fine and have the correct number of in outs

im wondering if the same issue exists for AC/DC

For reference, what I see in pw-top:

I   80    256  48000   6.2us   4.5us  0.00  0.00    0    S16LE 2 48000 alsa_output.usb-Rebel_Technology_OWL-LICH_355D35643239-00.analog-stereo
I   98      0      0   0.0us   0.0us  ???   ???     0    S16LE 2 48000 alsa_input.usb-Rebel_Technology_OWL-LICH_355D35643239-00.analog-stereo