Lich build knob scale issue

So for some reason after finishing the build and playing with the demo patches I’ve noticed that my A knob behaves weirdly e.g. when controlling oscillator pitch with it there is not pitch change unless I turn it past 2 o’clock and then the value increases drastically until the end of the knob turn range. This behaviour is somehow similar to logarithmic scale? I bought the full kit, and as far as I remember all pots looked identical so I don’t think the pot is mismatched. I am looking for any suggestion as to how could I troubleshoot this further :eyes:

Anyone? :grimacing:
I’ve tried resoldering the knob and the R112 but it did not help.
The A CV input appears to work correctly :thinking:
Could this logarithmic behaviour be caused by a cold joint or a short?
I guess the last thing I could do is to desolder the knob and measure it

Hey @Befaco what is the model of the U$2 pot on Lich? I’m not sure how to decode R1212NPAD_MINIS I have tried desoldering it but I don’t think I will be able to succeed without hot air station or some professional grade iron so I will have to cut it out and in that case I will need a replacement for it :disappointed:

Hey! You can get those pots from Befaco´s webshop.
Try meassuring voltage in the center leg in the pot and check how it behaves. Also, remove IC100 and measure voltage change in pin 2 to see if short is in pot ittself or in R112 resistor
Anyway, best place to get help troubleshooting a hardware issue is via