Lich with OWL3?

Oh wow, so you’ve finally started shipping it? And with no official announcement about something that major!

Moreover, I think there would be some demand for replacing OWL2 → OWL3 on existing hardware. Is the OWL digital board in store also the new version?

We are doing a soft transition, letting old stock to be sold and slowly introducing OWL3.
We will do an offical announcment “soonish”

HI! any chance to update from 2 to 3?

Simply replacing OWL board with new version and flashing correct firmware would be enough. It’s fully backwards compatible on hardware side. I think that they’re out of OWL2 board and will send OWL3 if you order it in Befaco store, but you might wait for @Befaco to confirm this.

Yes indeed!
Send us a mail to

If we’ve replaced the old OWL with the 3, do we need to flash new firmware for the LICH to function properly with the OWL3?

Yes, despite compatibility with previous version, the hardware changed significantly (new microcontroller) and requires a separate firmware version.

Oops, no one mentioned it when I got the OWL3 board. I should probably take care of this before reporting bugs on the system! Is the new firmware and update procedure available somewhere?

Update procedure is the same, just a different firmware file and bootloader version to use (Lich3.syx vs Lich.syx, etc). It’s available among v25 release files. That’s if they send it flashed with at least a bootloader.

Actually I’m not sure if @Befaco will flash Lich3 firmware/bootloader by default or not. It’s quite likely that this would be the case as it’s the first supported device for OWL3, other upcoming stuff (Witch, Magus and more) is not finalized yet. But in worst case it would require obtaining a cheap programmer and using it to flash the bootloader first.

Just picked up an mk3, looking forward to digging into it!

Is the i2c bus exposed for use to control or be controlled by other devices?

Nope, there’s no I2C support in OWL. That’s the short answer.

A longer one is that I’ve experimented before with it a bit, got it to communicate with Teletype. However, on Lich there’s no I2C header (unless you’re willing to do some soldering yourself).

Genius and Magus have I2C headers, so at least they wouldn’t require any hardware modifications. Btw, this is not really specific to OWL3 and probably deserves a separate forum thread if you’re seriously interested in getting this to work

1 Like

Sounds good, thanks for the info! If it was just a header that needed soldering on that might make the effort worth it, but tapping pins probably not worth it for community involvement. I could do it but I wouldn’t want others trying, just to get teletype communicating with it.

Besides using i2c2midi, I bet usb midi communcatioin would work, if I wanted to go that route… If I end up progressing any further down the path I’ll definitely start a new topic.

The OWL board just plugs into the main Lich PCB, right? So you can just remove the v2 and replace it with v3 without any soldering?

Yes, that’s what I did and everything worked well. I read somewhere that you have to update the firmware but it was still working fine before I did that. Now if we could just get access to the patch library…

1 Like

I think I killed my Lich…

I installed the new board and loaded some old patches onto it to see if they would run correctly. Some were not, so I tried installing the Lich3 firmware. I got a bunch of error messages, so I reset everything and tried the module, but all programs were putting out silence. So then I tried flashing the regular Lich 22.5 firmware and it went fine until I pressed Reset Device after the firmware upload completed. I got a bunch of Unexpected Reset errors, and the module has no display and no activity. Even after power cycling with the USB cable unplugged, no response from the module.

It won’t power up and neither the OpenWare site or the patch library can detect the device anymore. Anyone have any idea what I should do here?

What do you mean by “regular Lich firmware” - the one that was made for original Lich with old version of OWL board? They are for totally different hardware that is not compatible internally. So that can’t possibly work.

If you’ve flashed an incompatible firmware or installed a patch that causes a failure on startup, just keep the encoder pressed when Lich boots, it would force it to stay in bootloader mode and you can install a working firmware from it. Might be a good idea to erase patch storage in case if you’ve flashed a patch that won’t work.

In theory, it should be resetting itself to bootloader mode already, so it’s possible that you have some problem with your OS not seeing USB device when it changes its type from composite MIDI + audio device to MIDI only in bootloader mode. Something like this happens on certain versions of Windows.

Thanks for the reply antisvin!

I started the module up with the encoder held down and the firmware and library tools recognize the module again. I cleared patch storage, but I’m not sure what to do about the firmware at this point and want to check in before I make anything worse.

Openware recognizes the device as OWL Lich3 Boot v22.5.0, which makes me think the firmware is still installed. Should I just try powering off the Lich and rebooting, or should I go ahead and try to install the Lich3 firmware again?

It’s unlikely that you’ll make it worse, you’ll just end up going through the same process to flash another version of firmware in worst case. Bootloader is flashed independently from firmware and it should always be available.

That’s not firmware version, but bootloader version build from the same code version as firmware v22.5.0. Current USB problems seem to happen only with code that runs in firmware when where it’s a composite audio + MIDI device, while MIDI-only driver in bootloader is fine. So what you should probably do is downgrade firmware to something that works and wait for firmware update that solves USB issues.

Unfortunately there were multiple bug fixes in v22.5 and just staying on older release may not be that great. Also, I’ve experimented with a few versions of USB libraries and got it work with v22.5. I’m not sure if it’s still usable as an audio interface (it will be present, but might miss some enhancements that were added later), but at least the MIDI part worked fine for me.

1 Like

Thanks so much! Seems to be working now. I’ll test out my patches and try out some prior firmwares if they aren’t working.

I also have problems with the Owl MK3. I can’t load almost any patch. It gives me an error: Error 0x60 Invalid SysEx checksum.

FIRMWARE: Lich v22.5.0
MESSAGE: Loading 100
ERROR: Error 0x60 Invalid SysEx checksum

Usually, when I go several days without connecting it to the computer, the first patch I load works fine, but the second one doesn’t load anymore and gives me that error.