Modular Newbie: Pitch question

Can’t get Lich oscillator patches to play in key using Moog GM key out at 5 or 10v or beatstep. Kind of plays Octave over 2 octave range and increasing voltage from Moog just generally increases pitch rather than play notes in key / to known musical intervals. Any ideas of what I can try or what I’m overlooking?

Have you calibrated it?


It’s a factory build so doesn’t need calibration according to Calibrating Befaco Rebel Lich - YouTube. I would do it if I had a voltmeter though!

Anything else to try?

Are you running the same firmware version that was installed initially or made some upgrades?

Nah… too much of a newbie to do anything off grid. Just updated to latest version of firmware.

Calibration settings are stored in patch storage, so you would lose it if you erase it. There have also been some firmware releases that used a different (larger) flash chip on OWL, causing it to lose old data. Either way you’ll have to recalibrate to use latest firmware. If you haven’t erased patch storage, you could downgrade firmware to whatever version was initially installed instead.

We have also discussed with @mars a simpler calibration procedure that would require precise CV source instead of multimeter, but I’m not sure if he’ll end up adding this to firmware or not.

Ah yes. Firmware upgrade wiped the 4 patches on there for me following the guide.

So no option but to get multimeter then?

I think it may be possible to retrieve settings that were previously used if you install the old firmware version (probably 22.1 or older release

You should see those old patches instead of what you currently have installed. If that would be the case and you can confirm that tracking works, it’s possible to retrieve calibration settings with MIDI commands and set the same values on new firmware.

I’ve restored older firmware but not showing the 4 original patches or changing pitch behaviour. Either no patches or last one I did restored the 14 I put in yesterday which I wasn’t expecting?

Ah sorry, guess we need something older like this one

That reset to 4 patches. But they’re the patches I put on rather than the original 4, unfortunately. With same behaviour.

I’ll get a multimeter tomorrow and give calibration a shot…

Flip me, calibration is not easy. Multimeter didn’t come with crocodile clips so isn’t easy to have the 3 or 4 hands to do this. So not getting accurate enough readings.

Any tips other than getting clips?

No tips about reptiles from me, but here’s a tip about resistance

What about amphibians?

Well it’s calibrated perfectly now (using DC which I’m presuming is correct). And doing exactly the same via Moog kb out and via Beatstep as before. So not playing in pitch at all.

I’ve tried with another oscillator and that plays in tune.

Any other ideas or does this need to go back?

Just to make sure, are you sending pitch CV into audio input? What you describe sounds like a result of trying to control it with attenuated parameter used for tuning knob which won’t work for V/Oct signals.

Generally you can’t have problems with tuning unless you also have problems with audio codec and that would give you noticeable distortion for any patch that processes audio. All that calibration does is tell the firmware how big is the digital value that you get per 1V of input signal and how many volts from 0V is your digital 0 signal.

Thanks for helping!

I’m sending cv out of beatstep and kb out of Moog GM to CV A? Connecting to audio in does nothing to change pitch. Plays same note whatever key is pressed.

Yeah so typically you would use the left input for V/Oct signal, it’s the same one that gets calibrated. This is usually mentioned in patch description.

You could still use CV A input for something like vibrato too, i.e. when you don’t need V/Oct control and want to be able to attenuate signal amount. Otherwise just use the knob for parameter A to set root frequency.

Thanks again @antisvin for persevering with me. I would have given up without you. I owe you a :beer:

So… reset firmware again to n-1. Calibrated again. Still no note change on audio in.

Tried something radical and switched negative and positive voltages in calibration to shake it up. It played keyboard notes backwards - so something was working! Then switched voltage back again and BOOM! It works :grinning:

Calibration must have been toying with me and doing nothing the last few days? Who knows. Off to play with PD template now I know it works. Maybe random sequencer first …

There’s an obvious reason why you could get an opposite voltage sign - this would happen if you swap ground and voltage probes connection on your multimeter. A very common mistake to make. The audio jacks connect ground to jack sleeve.

Either way, congratulations with getting pitch CV working!

Yep, agree. Multimeter correct all along, I just put opposite values in manually in calibration page in desperation. Desperation did something!