MPE issues - linnstrument

I appear to be having the same issues as the person with the morph - the witch doesn’t appear to be able to cope with the stream of midi it receives and freaks out in various ways - locks up, volume lowers, sustain gets stuck on.

Has anyone successfully had this running in MPE for more than two notes at a time, with everything working as should? (ie consistent slides, velocity response, volume etc)

Quick thing to try out:
change the patch on the Witch (to an Expression patch) with the Linnstrument connected

This will resend the MPE configuration messages to the Linnstrument which should configure itself with the correct amount of polyphony et c.

Thanks, I’ve switched between patches but I find whatever patch I select drops out (red lights) with chords, slides or quick playing - for example a five note chord will either toggle sustain, mute the patch or red light it.

Just to expand further sometimes a four note chord will freeze it (red lights), sometimes when its frozen I can select a new patch, which is sometimes muted in which case I can raise the volume with the linnstrument, sometimes its a brick - I’ve tried various different channel configs but so far its struggling, I perhaps wrongly assume with the volume of midi?

And to go a little further I’m currently having no issues if I turn all the continuous data streams off on the linnstrument - so if I manually set x, y and velocity off the witch is fine.

I’ll see if I can work out which the witch doesnt like, but my initial thought is that it can’t handle the ammount of data sent when in full mpe. I hope I’m wrong there?

EDIT: It certainly does not like y axis data. Instant crash.

Maybe try this (in global settings):
" Hidden setting: USB MIDI Data Reduction

If LinnStrument’s high volume of MIDI data sent over USB is overloading your computer or sound generator, you can slow down the transmission rate of MIDI messages. Hold the “USB” button to display a screen showing the delay time (in microseconds) that is added between sent MIDI bytes. Swipe left or right to change the value. Default is 235. As a point of reference, a value of 300 slows it down to the speed of the MIDI jacks, and a value of 600 slows it down to half the speed of the MIDI jacks."

Ooh, nice one - that appears to be a step in the right direction… Im still getting the odd hang but its lots better. Ill experiemnt with different settings… Thank you!

1 Like

Have you tried updating Linnstrument firmware, btw? Maybe worth trying that too.

On OWL’s side, it may be possible to increase MIDI buffer size to be able to receive more messages at once. But this would require recompiling firmware. So if all else fails, we can make a custom build for testing this.

It would be worth trying since I suspect that was the issue with the morph too…I have a morph here too so it would be worth trying to fix the code witch side. I think there’s a new Linn firmware too so will update that as well to rule out. Thanks again!

We’re trying out a change in the MIDI processing so that messages are processed before each audio block instead of in a separate task. The trick was to fall back to the previous method in case a patch is not loaded, or fails to run.

I’ve made a pre-release for Witch and Lich:

Would be great to get this tested with some MPE devices, the Linnstrument in particular, to see if this doesn’t improve performance significantly. Let us know if you try it @tIB!

1 Like

I will! Hopefully get to it tomorrow - I’ll try both devices (linn and morph) and will let you know…

1 Like

Sorry, life got in way. I’ll try again tomorrow - any documentation on how to update?

Yes absolutely:

You might not get a Firmware Flashed message at the end, depending on the mood of the bootloader at the time. In that case just wait 2-3 seconds then power cycle and reload the page to verify that the new version is running.

1 Like

Right so tested this morning with both - no joy I’m afraid; same behaviour really, in that unless I slow the midi transfer on the linn it freaks out. I couldn’t actually get the morph talking to it properly but I suspect that is in my morph config, which at this point I probably won’t look into - I guess get it working with the Linn first and then look at that my end?.

Y axis definitely makes things worse when on - with y axis data off linn side I can play faster/chords without hanging usb speed 235, but when on I need to slow it down to 300 or so otherwise fast playing/chords freak it out.

I get a lot of false startups too with that firmware, in that the witch hangs a lot when I power on/refresh - I often get that anyway, but this seems worse?

Just to put things into perspective, I don’t have problems with Linnstrument on OWL, but that’s not with Witch which I don’t have (yet). And it feels like those changes that Martin added have decreased latency that I get when playing Linnstrument.

It’s possible that Witch has higher load than other devices because it performs more processing for CV (smoothing, dealing with parameter takeover, etc). So some MPE patches that are intended to use a lot of CPU time don’t have enough time to process large amount of MIDI data. It can be verified by making a less CPU intensive test patch (i.e. with effects removed).

And if CPU load counter only measures audio processing time, it can’t be used for detecting load generated by processing CV and MIDI.

To be clear the issues I was having were (mostly) sorted if the midi speed was decreased linstrument side. The two things do work together.

Edit- I wondered about latency on the new one too.

After more play I’m finding things a bit unreliable.

So just to expand once on and patch loaded, with the linnstrument set to lower usb data transfer I can play duophonicly without issues.

My frustrations lie in the unpredictability on boot - often (as in more often than not) with the Linnstrument connected, the witch hangs on power up. It also struggles to switch between patches - I get silence and/or pitch issues, requiring power cycle which causes more hangs. It’s a frustrating start to life with the witch.

I guess how far I go with this depends on how easy it is to make some tweaks to the current patches - on the subtractive synth I’d like to link Y data to volume for example, or possibly distortion. I need to do some figuring of how to adapt puredata patches to be controlled by the witch too. At present this seems quite a way off given I can’t even reliably power the device on, but we’ll see…

As a side issue I couldn’t load samples into the sample player reliably via the browser either - it seems whatever I’m trying I’m running into issues.

And I’ve just tried powering without the Linnstrument connected - 7 cycles for the witch to boot into the selected patch. It’s not good.

Unpredictability on boot: this is not something I recognise as ‘normal’ behaviour!

Could there be some problem with your Mode button, that it is jammed or unreliable?
When you press the Mode button, one of the LED buttons should light up to indicate the active patch. Is this working reliably?
Or problems with the power supply - are you powering by USB or DC jack?

Not good at all! This would be the first thing to resolve, before tackling the Linnstrument problems. Is your Witch built from kit or pre-assembled?

It certainly like a hardware issue. How about a custom firmware build that uses one of the LEDs as indicator for any EXTI being triggered? I.e. to confirm that there’s no floating connection on any EXTI enabled pins overloading the device with interrupts storm.