New firmware: OpenWare v21.2

I am happy to announce we have a new firmware release: OpenWare v21.2.

This release fixes a couple of USB issues, notably that parameter changes over USB Host weren’t working in the previous release. It also lays the foundation for better support for patch resources, such as samples and wavetables. See the release for full change log.

This is also the first OpenWare firmware that we are providing OWL Pedal and OWL Modular binaries for! A few brave souls have already flashed OpenWare on their legacy hardware, but with this release it is now an officially supported upgrade path.

To upgrade a legacy device, the process is fairly straightforward. I’ve made a custom version of webdfu to hopefully make it a bit easier.

  1. download the firmware binary from the release page, either OwlPedal.bin or OwlModular.bin
  2. connect the OWL in bootloader mode (hold down LED button on startup)
  3. open OWL webdfu (with a recent version of Chrome or Chromium)
  4. click Connect to OWL and Choose file to select your downloaded firmware binary
  5. click Flash firmware and wait for the process to finish

Alternatively you can use dfu-util instead of webdfu. The command to flash the firmware with dfu-util is:

# For OWL Pedal
dfu-util -d 0483:df11 -c 1 -i 0 -a 0 -R -s 0x8008000:leave -D OwlPedal.bin
# For OWL Modular
dfu-util -d 0483:df11 -c 1 -i 0 -a 0 -R -s 0x8008000:leave -D OwlModular.bin

After reset, the device will no longer have any factory or user patches stored. Instead you will be able to load new patches from the patch library and store them, using slot numbers from one and up.

I do not recommend upgrading the bootloader at this stage! In the future we will provide an upgrade path for this too, so that legacy devices can also run the MIDI bootloader. But it’s not ready just yet.

2 Likes

I’ve pinned this topic to be on top of “Firmware” category until September. It’s probably better to do it for all important announcements.

1 Like

As reported by one of our users, the OWL Modular firmware v21.2.0 has a problem: parameter values end up reversed for parameter A to D.

I’ve updated the OwlModular.bin and .syx firmware images to v21.2.1 which fixes this problem. Same release link.

If you have already flashed OWL Modular v21.2.0 then please re-download and re-flash with the new binary.
You can check the device page to see which version you have.

Is it OK that Lich bumps to version 22.0-pre ?

Hmm it looks like @mars was too eager to release things and the used wrong branch for Lich. AFAICT, this is from the branch that has some experimental code for patch storage, so you may run into some issues. If that happens, downgrade to previous release, otherwise I can build correct firmware version. Or just wait until Monday when he’ll likely replace that file with intended version.

Until this is resolved, it’s probably better not to install Lich firmware for anyone that hasn’t done it yet.

1 Like

@antisvin, thank you for your proposal
but I’ll just wait until firmware is correctly updated by @mars

What?! Oh no! What a blunder! Sorry @per and anyone else who accidentally got an experimental v22.

Fixed now:

This is a good prompt to start putting some more automation in place - machines don’t make mistakes, right? At least not as frequently as I do!

1 Like

Maintenance release v21.2.2 published now.

This is an advised upgrade for Wizard and Alchemist devices.
Otherwise there’s no need to upgrade to this from v21.2.1, if you already have that installed.

(binaries built with the new python build script from @antisvin!)

2 Likes