No output from Alchemist


After working for a few weeks my Alchemist is no longer outputting any signal, I’ve tried connecting headphones directly (as opposed to through my mixer) and using an oscillator patch to ensure a signal is being generated, however there is no signal at all. I’ve also ensured the volume is up on the device by holding the top left button and turning the C knob fully clockwise, but I still hear absolutely nothing. I can communicate with the device successfully from the site and I’ve tried resetting the device, and erasing the storage. I’m out of ideas now though.

Thanks for your help,

This turned out to be a red herring, Chromium (on Linux) was reporting all was ok connection wise, but it was only when I switched over to Chrome (on my Mac) I realised there was a connection error with the device. So I attempted to do a firmware update, 20.7 has failed three times now, after I restart the device the led is red and nothing happens. So I tried version 20.5, which looks like it’s successful at the end since the led is green, but I get the following error:

Program Error 0x60 Failed to start program task

and restarting the device brings back that red led, and I again see the above error.

Is there a more reliable version I could downgrade to?

Oh jeez, this has been a voyage of discovery. So I’m back at square one, I’m assuming that the above error was just down to wiping the storage, and when I loaded a patch ignoring the error it worked. The bad news is I still have no output at all. I’ve upgraded again to 20.7, but this was futile. I think my unit is faulty, I’ve had it for less than two months and it’s had minimal use. I’m quite disappointed, as I do really like it.

Yeah, the error you saw was just result of firmware upgrade - I think it’s just a failure to load patch in such cases. You should probably wait for Martin’s response, but to me it looks like a hardware issue.

When I had some problems (which were due to me messing with firmware), I was told to send an email to info at rebeltech dot org if I want to arrange return for fixing. Pretty sure that this is what you’ll also hear.

1 Like

Hi @danh, yes email me to arrange a return please: info at rebeltech dot org just as @antisvin says!

For the record, the things to try in a case like this is:

  1. connect headphones directly to the front minijack socket
  2. ensure you have a simple, working patch that you know produces sound (e.g. this one)
  3. make sure volume is up

Since you’ve done these things already I think it’s best to send it back to get checked over and fixed.