Output Noise On Magus, Please Help!

Has anyone got any thoughts/experiences with the audio output and noise.

I have tried.

Usb with filter from a laptop
Usb from 3 different wall power adapters
Usb from 3 different battery banks
DC power from 2 different power supplies
DC power from usb to dc boost converter.

None of these configurations yield and audio output with a noise floor that is quiet enough to be usable as part of a performance setup.

I’m enjoying what i have been making in puredata, and am dipping into faust, but regardless of what I do, my own patches or others… i just cant seem to shake the noise. Which is making the devices a little unusable!

This applies to both the stereo jack output and the mono ones. Also doesn’t seem to matter what I plug it into. On some it is defintely not as bad, but still unusable.

Any help would be amazing. Its running latest firmware btw.


Generally you should avoid powering from USB - it’s outputting a rather noisy signal. Difference between powering by USB and from external PSU should be quite considerable.

There are still a few ways to use USB and avoid noise:

  1. Use USB isolator - may help, but there’s a chance that USB itself won’t work or it may not provied enough power.

  2. Use USB splitter - this takes power from external PSU and avoids noisy USB power. However, it won’t be less noisy than just powering from external PSU.

Do you connect your laptop when you test this? Maybe try without it. Also, you can try dimming LEDs in device settings, this may lower noise level. It’s a good idea to compare noise in stereo and dual mono outputs - they may differ in some cases.

The device itself has some components that are prone to generating noise - OLED display and LEDs that are controlled by PWM. So I’m not sure if it’s even possible to bring it down to the level that you’ll find acceptable. @mars was experimenting with PWM settings to decrease noise but that caused some other issues and is yet to be solved.

Turning the Leds off has solved this for me, even on usb. Noise floor is well within acceptable for my uses. Leds were set to max!

Thanks for the pointer!

Ah that’s great. I think that means that we should lower the default value used for LEDs if they’re just set to the max.

Regarding USB usage, make sure that you’re also not getting noise in inputs as well - e.g. run a patch to bypass audio). I’ll be surprised if you won’t notice noise from USB under any circumstances. OTOH, my Magus is from the original kickstarter and I know there have been some tweaks to its internals since then to address some power/noise issues.

I’ll do some testing with some bypass and my original patches, and the various power options again and post just for reference if its helpful :slight_smile: