Owl not working out of the box, cannot see OWL in the Device Manager

(some additional info on what was happening to the pedal before I started messing with OwlNest to make the situation easier to debug)

The Owl arrived today and as soon as I got the power supply and read the included manual I plugged it in, it turned out the patches don’t work as expected or weren’t preloaded - instead of the footswitch switching between “red” and “green” LED lights indicating the 2 preloaded patches, I had “red” and no light (IIRC). Both of those settings didn’t do anything to the sound - both of them sounded like they were the “bypass” channel.

Afterwards I tried plugging it to my computer (Windows 7 x64) to assess the situation. I run the OwlNest and blindly tried “Load from OWL” and “Save to OWL”, but it didn’t make any difference. Both the Green Slot and the Red Slot lists were empty. It also turned out I can’t change the input and output in the “Application Settings” tab, and The OWL isn’t even present in the “Active MIDI inputs” or “MIDI Output”. Which I guess makes sense, since the Owl doesn’t show up in the Device Manager - I tried different USB ports and it doesn’t make a difference.

After this, when I unplugged the Owl from the PC and back to the instrument, it turned out, that the footswitch didn’t turn any of the diode lights on - the light is off all the time (even when it is connected to the PC). Now it seems like the footswitch switches between “bypass” and “no sound”.

It seems like the Owl isn’t working properly. Is it something I can fix myself? What do you suggest I do?

Sorry for the wall of text, I want to provide precise and verbose information to help pinpoint the problem. Let me know if there’s something I can do to help you guys debug it. I usually use Xubuntu, but this time I used Windows to use the precompiled tools to get going faster.

PS. my Owl has some parts rattling inside of it, I’m not sure if this is within standard or something out of the ordinary.

Hi there!

There are two buttons on the pedal: the footswitch, which switches between effect and true bypass (which also turns the LED off); and the pushbutton, which is integrated with the LED and switches between the red and green patches.

The pedal must be plugged in before starting the OwlNest. There have been some reports on Windows that the pedal is not recognised at first as a MIDI device. The solution seems to be to remove and reinstall the driver, or to install an alternative class-compliant MIDI driver such as the Korg one. Please check the forum for instructions.

Rattling: there is a piece of card inside to protect the back of the PCB. We didn’t want to glue it down - it can get messy if you want to remove it!

Let us know if this information helps your situation at all.

I don’t know how I could have missed the LED pushbutton, I feel kind of stupid now :confused:

But the problem still stands - I checked the device with 3 different computers, and neither of them recognizes it - it doesn’t even show up in the Device Manager - unlike in Neil’s situation, where the device was recognized by the system, but there’s a problem with the driver.

I checked the supplied cable with a different device and tried different computers (with Korg drivers installed on one of them), cables and ports - no sign of life from any of those. When I plug the Owl to the instrument (and the power supply, naturally), the only thing that works is the footswitch - I get the bypass or nothing. Nothing I do makes the LED light up and I don’t get any sound from the device when it’s not in the true bypass mode.

hmm, that doesn’t sound good.
Can you enter DFU mode by holding the LED pushbutton down while you plug in USB?
It should blink red three times then go blank.

No, nothing happens when I hold the LED pushbutton down while plugging in the USB

Please email us (hoxtonowl(at)gmail(dot)com) and we will sort this out.
Thanks !