OWL pedal not connecting


after some time I pulled out my OWL pedal (rev4) and I was having a blast trying to get my first non-experimental patch done (a rotary speaker).

After nearly one week playing with it, I left the pedal perfectly working one night, but unfortunately the following day the button led shown no signs of life, and the pedal was no longer recognized.
No stressful events whatsoever, powered only by USB cord from PC until then.

Being not possible to enter programming mode by pushing the button, I found information on how to force DFU mode with two wires.
Tried that, and to my surprise, since it was apparently totally bricked, it flashed the firmware. But after cycling power, the device again shows no signs of life.

Tried the procedure repeatedly, with all the firmware versions I could find, tried powering by PSU after removing the red jumper inside, tried separating the digital board and testing it alone (required two more jumper wires).
But always to the same result: the pedal is visible and flashable in forced DFU mode, but otherwise is completely dead and non responsive.

I was wondering if someone could give advice, if there is something else that I could check, i.e. voltages on regulators outputs, etc.
Because if forced DFU works, then the CPU/flash should be (mostly?) ok, right?


Hi Alessandro,

I would suggest flashing bootloader in DFU mode first and then using it to flash latest firmware version.

You can use the bootloader binary from MidiBoot-Pedal.bin file from here: [solved] Can't connect to Magus - #21 by antisvin

Make sure that you use correct flash address for bootloader ( 0x8000000). Firmware address is 0x8008000 and confusing the two would give you a device that doesn’t boot.

If you don’t see a MIDI device named OWL-BOOT after flashing bootloader, this looks like a hardware issue.

I used the WebDFU, not the command line one, and it only shows flash ranges, no option to change the base address.

Tried again with the MidiBoot_Pedal.bin, which I had not previously, but unfortunately made no difference. The WebDFU process, upload and flashing, completes without problems.
Then I click disconnect and power cycle the pedal. But at that point everything is dead (except the internal green led on the digital board), pressing the button while powering won’t work, no red or green light on it, and no MIDI device appears at all.

Noticed the size of the MidiBoot is much smaller than the 21.2.2 which I assumed was the latest.
Anyway all the flashing with the large binaries was ok previously, I had the pedal with an ancient version and updated to 21.2.2, which was working then.

I don’t know very much about STM32, but I’m correct assuming the update process is managed by the MCU itself when not using an extenal programmer/JTAG or the like?

This is what is puzzling me, the thing being in a sort of twilight zone between alive and totally bricked :rofl:.

Thanks very much for your answer, at least I tried.

Correct, DFU bootloader is just a regular program “hidden” on a separate part of flash that can’t be overwritten. Other than that, yes it’s executed by MCU just like regular code. Which means that MCU itself is functional.

OWL DFU page is currently intended to only flash to firmware start address, I think address selection was removed because we didn’t plan to ask people to update bootloaders on OWL1 and it would be too confusing. But it was possible to choose address on the original webdfu page.