OwlNest Rev04-004 Binaries

The new release is up on github.

Windows binary by sgissinger: thanks Séb!

Hi. I’m following the instructions to update the firmware via OwlNest but I’m getting “probing for DFU device” and then “could not find a connected dfu device” at 16%. The app then stalls. The pedal also becomes unresponsive until I disconnect and reconnect the cable.

Had a hunch, and turns out I was right. I tried updating the firmware on a Mac at my office this morning and it worked like a charm. The OwlNest software simply doesn’t work properly on my Windows 8.1 64-bit system.

Please look into this!

Hi Sleeven,

have you tried this procedure ?


Hi Giom,

I have not tried this. Didn’t know the page existed. I would suggest that you put something about this in the ‘How to update the firmware and get the latest patches’ section of the Getting Started page – rather important info for Windows users!

I will give this a go, thanks. Do I need to switch back to the standard driver after making the firmware update, or can I leave it as is? Also, will this issue be resolved in a future update of OwlNest?

Thanks again,


With the OWL in DFU mode, what does it show up as in your Windows Device Manager? It should say something about ST Microelectronics DFU device (ST is the microcontroller manufacturer).

You are right Sleeven, I am updating the wiki so it appears more clearly.

Hi mars and giom,

Sorry for the slow reply; was away on vacation. First off, thanks for the advice. Following the directions on the wiki page you supplied did the trick. In DFU mode, my OWL was listed as STM Device in DFU Mode (if I remember correctly).

Thanks for updating the wiki!