Pingpong echo problems

My pingpong echos sound modulated and noisy. Any clue as to the problem?

There’s a few steps to making smooth delays, like parameter smoothing and buffer position crossfading. You’ll also normally need a dc filter to prevent feedback loop saturation.
Did you have a look at Cherif’s Max Gen delay tutorials? They’re great, see