Possible bug in online pd compiler? Or maybe I'm an idiot

So my end goal with what I’m trying to do here is that I want to expand the function of the knobs on the owl. I’m trying to use spigot to switch what parameters each knob will affect with the press of the push button. I was originally trying to create a simple 8 band eq by having the four knobs before having pressed the button affect the first four bands and then when you’ve pressed the push button it would have the four knobs affect the last four bands. However this does not work as I intended. Below I have created an even simpler patch just to showcase the issue. In this patch there are two oscillators continuously going and the A knob is suppose to just affect the frequency of only one of the oscillators at a time and when you press the push button the A knob would then switch to only affecting the other oscillator. However when I press the push knob in the online patch it somehow affects the other oscillator’s frequency and doesn’t even change which oscillator the A knob affects. I created equivalent objects to represent the push button and the knob (the hslider being the A knob and the push button being one of the toggles) just to make sure I was doing things correctly and it works fine before being compiled. Be aware I do not own the Owl Pedal yet so I have not tried it out on the physical hardware otherwise I would have tried so it might just be a bug in the online patcher or maybe I just don’t understand the Owl well enough perhaps? because doesn’t the push button just output a 1 and a 0 if pressed? Any help is very appreciated. Here is the patch: https://www.rebeltech.org/patch-library/patch/untitled_bac15ab4d733

Ahhhhhh I think I see the issue now. The Push button acts like a bang and not a toggle lol. Jeez I feel real dumb now that i didn’t think of that. Still doesn’t make sense to me why it affected one of the oscillators though. I’ll retry making the patch with this in mind though.

Ugh. Well darn it actually still has the exact same problem as before even after remaking it knowing the Push acts as a bang. Gotta say I’m pretty miffed and confused cuz I have no idea why it’s acting this way :thinking:. Here’s where it’s at now: https://www.rebeltech.org/patch-library/patch/untitled_f4bbe035b557

Hey for me this seems to work. On the press of the button I hear either the saw or the the sine, the A knob allows me to change the frequency…

did you have other intents?

Do any of the frequencies change when you press the push button? Because you shouldn’t hear any frequency change when you press the button. Pressing the button is only supposed to change which oscillator is being affected by the A knob but it’s not supposed to actually touch any of the frequencies. You can easily copy my patch in pd yourself and see the difference if you’d like.

Huzzah! I figured it out. So all of the parameters (knob a, push button and so on) are constantly outputting what number they are on instead of only outputting when they are changed (which is personally how I think they should work.) So to prevent this from happening in pure data all you have to do is put the “change” object in front of each of the parameters which will therefore stop them from outputting the exact same number without it being changed.