Saving into the OWL Pedal

Hi, I’m back using the OWL pedal again, and I’ve forgotten how to do things in the meantime. I’m using V14 firmware, I think. I’m trying to save a gen patch to the OWL (there’s a button in the Max template), but I don’t know how to actually do the save into the OWL pedal. The and various other links don’t seem to work any longer, and the digital certificate seems strange (it’s from China…).

So what is the procedure to save a gen patch into a user slot?

Oh yes, and how do I check what firmware version I have? (And how do I update it?)



This should help with Max patches and explains how to load them on device - OWL Max Tutorial 1: Getting Started – Rebel Technology . Old site has been shut down a while ago.

Regarding firmware, there is newer codebase that is used for devices that followed Owl. It supports Owl as well, but with some limitations (i.e. patch switching on Owl using hardware button/knobs is not implemented - you’d have to use MIDI). But it allows overwriting all patches, not just the last 4. So you may consider using it (and I think rollback to old one would not be a problem). It can be downloaded from here - Release OpenWare v20.3 · pingdynasty/OpenWare · GitHub if you feel like giving it a try.

Excellent! Thank you!

OK. So using Chrome I can load patches and they work on the OWL fine. But when I try to Store, then I get this:

LOADED PATCH: mrSinesAtmosphereToggle0
Missing or Invalid Program 0x60
MESSAGE: Invalid program slot

I tried slot numbers from 0 to 40, and all gave the same result: RED led, and no sound…


OK. So I uploaded a new patch, loaded it and it worked. Saved and Compiled it, loaded it and it worked. Tried to Store it - no audio, red led.

As far as I remember, old firmware accepts user patches in slots 0-3 (however they are actually assigned patch numbers 37-40). I think there were some issues with using slot 0 in some cases. Also, there’s a possibility that web UI needs patch number and not slot number. I would expect either 1 or 39 to work for you (I think it should be the former).

If choosing different patch number won’t work, you’ll have to wait for Martin to troubleshoot this. Or somebody else may be able to help.

Hmm. I tried 0 to 40 (I assumed that 40 wouldn’t work if the number range started at 0!). 0 to 3 as the user slots makes sense… OK. Thanks for your help.