Sending CV via ACDC, patch needed or something else?

I just got a Befaco Rebel AC/DC since I needed a DC-coupled interface to run SuperCollider into my Eurorack. MacOs and SuperCollider recognize the ACDC just fine (as OWL-ACDC) and I have no problem to send audio in either direction. However I don’t get CV signals to work.

I tried to send CV from VCV-rack instead to make sure the issue was not in my code, but the results were quite random - it worked for a while, then again it didn’t, and there was a lot of noise. For sure it was interesting to listen to but not what I intended :slight_smile:

Any help or suggestions? Might there be an issue with the unit itself, or will I need some patch to run it as a DC-coupled interface? There is not much info in the manual.

There is a HPF that blocks DC on the codec used by ACDC, but in order to enable it you would have to build a custom version of firmware with modified config. Which means that you should have no problems with DC signals with stock firmware build. It’s hard to tell why you have the issues you’ve described, but have you tried using a larger buffer size in your audio device settings? Also, what happens if you send CV into ACDC - can you see it in VCV rack?

Regarding the default patch, it only adjust input levels and sets LED intensity and clipping indicators based on the result.

In worst case you might just have a faulty unit, then you could contact @Befaco about replacement.

Thanks so much for the reply @antisvin I appreciate it.

I did a test with a LFO from VCV-rack back and forth via a Mordax DATA oscilloscope. It seems it sends triggers or short gates rather than continuous CV (DC). If I pull the signal back into a VCV Scope it seems it’s the same as I can see on the DATA. Here’s a short video, unfortunately the subs are in Swedish but I added a translation in the description.

So weird

Ok, so basically you generate the blue LFO in VCV and get something that resembles it, but only 1% of data arrives. At least I get the impression that the output signal changes its level along with LFO. And USB capture still works correctly. So this looks like some issue with USB audio output, might be either a faulty ACDC or you may need to reconfigure your audio device settings. It’s also possible that the problem is with clock on this particularly PC, so testing on some other host might be interesting.

I don’t quite understand how can it work with audio at the same time, maybe it worked initially and then stopped?

@mars might have some better suggestions (and he can read swedish subtitles too)

And there’s one more thing to try - you could give pre-release firmware a go, because it does have some improvements related to USB audio synchronization.

Thank you, these are great suggestions. I will try with a different Mac, to see wether it could be the USB. I will also test the ACDC in another position on the rack, who knows what’s going on. And yeah, weird, it works great with audio. As I bought the module new I wouldn’t be comfortable in trying out new firmware, in case I will have to return it (I guess that could void any warranties).

I did another test with the HW CV Instrument in Bitwig, just the tuner function on two different VCO:s. The tests seem to work fine from the 1V/octave perspective, but the noise and signal shape is just weird (the green signal is what’s coming from Bitwig with the ACDC)

That definitely won’t be the case here. Also, a new stable firmware version was released yesterday, so it’s worth checking it out.

The firmware flashing procedure for the board used on ACDC is explained here . Firmware binary can be downloaded here . I would recommend also recommend taking a note of which current version you’re running in case if you’ll have to downgrade for whatever reason.