[solved] Please help - Many issues with Wizard after attempting a firmware upgrade

Hi, Please Help!
I don’t know if I’ve broken my Wizard or not.
First of all if I try to turn it on normally I get a really quick purple flash on the LED then nothing (Black). The unit doesn’t show up on anything in this state.

(also sorry I had to break some of the links below by putting the http in brackets as I’m a new user)

When I go into boot mode, this seems to work as expected I get the red, blue flashing before staying on red. However I can’t get this to show up or work on my windows 10 PC. I get the following results in the following situations.

When I go to (https://)rebeltechnology.github.io/webdfu_owl/owl/ I just get no device found, however if I go to (https://)devanlai.github.io/webdfu/dfu-util/ it sees the device but won’t allow me to upload the firmware.

If I connect via my mobile (with a wire, powering the device), in boot mode, I can go to OpenWareLaboratory where everything seems to be working OK and shows me that the OWL version is OWL MIDI Boot v20.2 but I don’t seem to be able to apply the wizard firmware.
The wizard won’t connect at all to the patch library or device manager (https://www.rebeltech.org/patch-library/device) under any circumstance/state.

Wizard also shows up in Zadig (2.5), when in boot mode, as OWL -BOOT (Interface 0) and shows the driver as WinUSB (v6.1.7600.16385) which seems correct.

Wizard does not show up in MIDI-OX in any state.

Please help, I feel really out of my depth and I’ve only had the wizard 1 day, not sure what to do. All I tried to do was update the firmware to the newest version.


You probably don’t need DFU, just regular sysex. It’s only required to upgrade the old OWL1 firmware. If you say that firmware upgrade didn’t work via mobile, you might try that with a browser on desktop (something like Chrome or Edge should work)

I’ve got a windows 10 PC and it’s just not connecting or showing up as I think it should. Defiantly not working via chrome.

When I try MIDI Sysex file transfer utility it comes up saying “No MIDI output ports found. Please connect your MIDI device”. I get this regardless of in normal mode or boot mode. I don’t know how to get it to show up?

Hi John,

don’t worry, we’ll figure this out!

@antisvin is right, you don’t need DFU for this device.

That’s great, it means that the MIDI bootloader is working. You will be able to send a firmware sysex file to this to reflash the device.

Okay so that’s what they call a generic driver. If you remove that driver and reconnect the device, then Windows will automatically configure the Wizard as a USB Audio device. It will then show up in Device Manager under [Sound, video and game controllers] as OWL-BOOT.

At this point you can go to the firmware upgrade page, using Chrome. It should say Connected to OWL MIDI Bootjust like when you connect with your phone.

Then flash Wizard.syx from release v21.2 and all should be fine!

Great mars, thanks for your help, I’ll try this and report back.

So I’ve tried a different computer altogether and the device, in boot mode, showed up as midi. So I went to OpenWareLaboratory and uploaded the wizard.syx from github. This all seemed to work fine. But the device is still not working properly, when I turn it on, not in boot mode, the light very briefly flashes purple but doesn’t stay on. I can find the device on the rebel tech patch page, and connect but nothing will install and the unit doesn’t seem to work. What should I do/try now?

Okay… something clearly not right there.

It’s worth erasing the storage sectors on the device, in case there’s corrupt data (settings or default patch).
Can you pls try going to the device page, in bootloader mode: click Connect to Device, then Erase Storage. Then restart and see if that changes anything.

If that doesn’t work, maybe good to try to flash an older version like v21.0.

Hi @mars, thanks for your help, after a lot of effort there is kind if life in the Wizard, it can take patches (that work). But firmware 21.2 (the newest one) doesn’t work at all and sends unit haywire, also the buttons on the unit aren’t working, most notably the mode button, so I can’t change the master volume or change patches. Is there something wrong with my unit? Again thanks for helping me out on this.

For your reference I could only get the firmware to change back to 21.0 using zadig, not the online tool.


It seems that the mode button and LED updates got lost in a code recent refactor and it wasn’t picked up in testing.

I’ve pushed a new release: v21.2.2

Please try upgrading to this version, and let us know how it goes!

@mars , fantastic news that’s worked! Thank you so much for your help!

I’m off to have a play with some of the awesome granular stuff now.

I’m also in the process of learning PD so hopefully I should have patches to share in future.

Thank you again,

1 Like