Web down and compiler broken

I wanted to understand why, for some time, everything on the web has stopped working:

  1. http://hoxtonowl.com/ doesn’t work
  2. the online compiler: OWL Patch Library – Rebel Technology always gives error… you think it cannot compile even the patches you made (GitHub - pingdynasty/OwlGenPatches)
  3. a slight disappointment for all this

Hey @pixfoil,

I’m not sure if it’s as bad as you say.

Hoxtonowl.com is the old site that got shut down last year, after most of its content was moved to this domain. There are a few threads here from old time users that were surprised by this, but this is not some kind of failure - just planned migration to another domain.

I’m not sure what error you get from the “My patches” page, but it works for me and I can compile patches that I have there. I’ve checked C++/Faust/PD only, so maybe there’s some issue with specific patch that you’ve tried.

gen always gives me error, both on my patches and yours (GitHub - pingdynasty/OwlGenPatches).
Pd compiles and plays on the web but when I send it to the own it doesn’t play anymore.
C ++ and Faust I don’t know (I can’t program)
Sorry but just a little angry for hours lost trying

Same here, the compiler works for me. @pixfoil - couldn’t you post details of your errors? That would make troubleshooting possible at all. Thanx.

I know how to program in max and pd (cc ++ and faust no) The compiler on the web does its duty and sounds right but when I send the patch to my own it doesn’t sound. I recently tried with PD and everything on the web seems ok but when I send the patch to my own it doesn’t work. In pd I discovered that the problem is on midi, the “notein” object of Pd is not well interpreted and the patch does not play midi. I make patches that have midi inputs to play them from the computer (I have published some in the user library).

pixfoil, i work with the OWL in a similar way, with PD and gen, though not using MIDI.

Browser transfer of any fresh compiled patches to the OWL doesn’t work here, the patch transfer somehow never finishes and/or the result plays dead. I didn’t have time to get into details there, just noticed, that an old patch from a slot is gone and the new one never seems to get completed.

So I have to download the compiled patch first and then transfer via OwlControl.
Especially the PD compiler would need some maintenance now i believe.
Didn’t test MIDI nor gen these days.