Befaco AC/DC - not recognized anymore

Hi together,

I recently purchased the befaco AC/DC. It was perfectly recognized by my macbook wihtin ableton, only the noise floor was very high but it worked.

My problems is now, that my computer (osx) does not recognize the module (as audio interface) anymore. By powering up my case the module shows the usual start up animation, so I think everything is alright. I tried to restart the computer and the eurorack case, dis- and reconnected but nothing brought it back.

Any hint?

Best,
sebastian

It might be possible to get rid of the noise, but it depends on noise source:

  1. If it’s coming from the PSU in your case, there’s no choice but to replace that PSU or try a different eurorack case

  2. If it’s coming from the USB connection, you might be able fix it with with a USB isolator

  3. If you’re using it to amplify sound considerably (i.e. with line level signals), you’ll be magnifying noise from the codec inputs. The solution would be to use something analog to amplify signals to eurorak levels.

Do you see anything in the patch library devices page? It could be that it crashes on startup and is in bootloader mode, then you will only get a MIDI device.

Hi and thank you for your reply. Indeed the noise might be because of my case. But now I cannot try another one.

When I connect the module with internal mini usb, I get the following:

Ok, so I suppose that @Befaco ship it with the default patch that acts as a digital attenuator/amplifier. If you send audio or CV into one of the channels and set its knob to the max, do you see the green LED shining? Input signal would be coming from respective output too and you can change its level with the knob.

If nothing like that happens, but you see the startup animation, it could be that you don’t have enough power in your case. What you might try is remove a few modules to see if it starts working after that.

hey very nice that you support in such a great way. thank you.

What I see is:

  1. startup animation
  2. green if I plug audio into e.g. ‘in1’
  3. red LED if I turn the ‘in1’ knob full cw

What I do not see nor hear:

  • no sound out of e.g. ‘out1’
  • no OWL soundcard if I connect to my macbook

But, it worked as OWL soundcard the very 1st time when I put the module into my case.
That is also the occasion when I realised about the noise floor.

is there a way to reset the module?

OK, so the leds are controlled by firmware, which means that it’s running. The thing is, USB audio is also controlled by firmware and it should be functional in such case.

You can have a look at info about flashing firmware here. Since the MIDI device is not visible, you’ll have to shorten the “BOOT” pin on it when the module is powered. If you want to do it and can confirm that you can see the DFU device in OWL-DFU page after that, I can build and send you current firmware image for flashing. Otherwise you could just arrange the return to Befaco.