Bricked Magus? Help!

Hi, I’ve had my Magus for a few months now and have enjoyed playing around with the library of online patches.
Last night I decided to erase the patches I had to make space for new ones. That worked fine, but after I tried to load the Dual Osc Delay patch the Magus failed to load it and power cycled off and on again. Now, when the Magus is powered on all 16 LEDS flash constantly and the device no longer shows up when trying to connect using the web app. Is there a hardware or software fix to get it back to life? I am reasonably competant with soldering and replacing internal hardware, less so when dealing with software, so would need some baby steps handholding if it’s a programming fix.
Thanks in advance

Hi Jon,

Most of the Magi in the wild have a problem with the way their bootloader works - there’s no way to force device to stay in bootloader mode instead of running firmware. So if firmware can’t boot for some reason, the device becomes effectively bricked. We have made an updated bootloader that forces bootloader mode if firmware doesn’t load. To flash it you need to have either a device that boots or use a programmer (ST-LINK V2/V2.1).

If you say that you’re fine with soldering, have a look at this topic that explains how to connect the ST-LINK programmer for debugging - Connecting programmer to Magus . Actually you don’t even need to solder in this case - it was written for troubleshooting firmware that runs on device, but you could take the digital board out of the case, connect programmer to pins from the bottom side and power digital board from its microUSB port.

We can guide you with necessary info for updating bootloader, after that you’ll be able to flash firmware. Which OS are you using?

Otherwise you can let @mars know if you’d rather send it for servicing.


If it is effectively bricked, then sending it back to us for a service is always an option. PM me for details.

Thanks, I’ve ordered a ST-link doohickey so I’ll open her up later this week and see if it helps. I was using the latest firmware which was in the GitHub repository.