Default behavior on MIDI CC input?

I am writing a patch that takes MIDI CC input and uses it to set output parameters. However, there seems to be some default behavior with MIDI CC changing parameters, which is interfering with my own efforts.

If I run OWL Patch Library – Rebel Technology (2019 Magus, OW v22.5rc1) with a Korg nanoKontrol2 plugged in, I notice that if I move the knobs/sliders connected to CC#1, CC#20, CC#21, CC#22, or CC#23, the parameter indicators on the screen (and the lights) rise and fall in time. (I see effects like this even when all parameters are configured as output parameters.) Maybe there are other CCs I didn’t notice because the nK2 doesn’t send them.

If this behavior is documented somewhere I don’t find it…

Is Magus/OW hardwired to convert MIDI CCs to knob/parameter values?
Is this documented somewhere? What are the CCs it responds to?
Can this behavior be disabled?

Parameters are controllable by MIDI CC, see firmware and docs

I think that it can’t be disabled. It’s possible to make OWL listen to MIDI data only on specific channel, but I’m not sure if it would be completely ignoring all data from other channels or passing it to patch without triggering firmware events.

Custom channel number can be set here in “Settings” form by sending “MI” and “MO” commands with channel number in the second field. I think that saving settings didn’t work for me recently though, so they would be reset on reboot.

1 Like


The NanoKontrol2 can be reconfigured so now that I know what the CCs are, I can at least change it to use CCs that don’t collide with the Magus’s…

I tried switching the NanoKontrol2 to channel 1 (instead of 0) but it appears the Magus listens for parameter changes on all channels.

The custom channel setting is an interesting idea but when I tried to use the linked page it would not work for me. What I saw was:

  • It always successfully connects and reads back the firmware version
  • If I enter “MI” “0” (or any other number) in the Settings section and hit “Send”, nothing happens
  • If I enter “MI” “0” and then hit “Store”, nothing happens for a second or so, then the Magus screen goes blank and stays blank until I power cycle the device. (Maybe it locked up and the watchdog kicked it into the bootloader?)