Digital Noise From Lich After Firmware Update

Just finished my DIY Lich and all seemed to be fine. After some general usage the signal became degraded and then suddenly turned into complete white noise. After some inspection there were a few suspect solder joints so they were tidied up.

Tested for smoke and voltage again. All fine. Tested for grounds and that too was fine, but still producing only corase white noise. The module seems to work in every other respect as well. Can load patches, will send the proper gate and CV. Its just digital noise from both L and R.

So Ive been experiementing with loading different firmwares and on some loads it will just work. But then after a few mins it’ll degrade and turn back into white noise. No clue whats going on.

Can anyone give me some ideas as to what to look for next?

Is this indicative of a hardware fault somewhere or is this a software thing?


Hello @rabalan!

Did you try erasing storage? This could help get rid of troublesome patches and settings.

Go to the Device page and click ERASE STORAGE, then wait maybe 10 seconds for it to complete.

This will delete all stored patches. After erase, try loading something safe like the Gain patch and see if you’ve got working audio through.


Thanks for your reply.

Tried that there. The erase worked but the white noise is still present. Tried another flash with the lastest firmware but white noise returns.

Few things:

There doesnt need to be anything patched in for the white noise to effect it. No patching with cables or the loading of an owl patch will change the white noise.

The noise isnt there when the bootloader is loaded. Only returns after firmware is loaded and device is reset.

After the device reset (or power cycle) the noise will grow in pitch and volume and stay constistent.

Is this a common thing for digital modules? Having a hard time figuring this out.

Right. So on some further experimentation. The noise starts when usb b is plugged in or the unit is bumped or rattled and can be stopped with a firm tap to the owl board.

Does this mean something loose somewhere but tbh I didnt realise digital audio could be so randomly analogue - like an old car engine lol.

I suggest you go over the solder joints that join the two boards, on both boards.

give it a good service and it’ll run like an F1 :slight_smile:

Resoldered the lot. Took off the pots as well which was a hassle but there was a few suspect joints. Reassembled it and switched on but the noise is still there. However there is a an area at the top of right of the owl board that if i press the noise goes away. There isnt any other area on the board that does this. Feel I am close to solving the mystery now. Could it be the owl board itself or do you think its still an issue with the header?

Thanks again for the help!

I wonder if it’s noise from the power supply, or something/somewhere else.
You don’t know or can find anyone local with another Lich that you could try swapping out the digital boards with? Just as an experiment to see if the noise follows the board or not.

It really does seem to be that one area. Once pressed everything works as normal. Audio and cv goes in and audio cv go out. No noise at all. Unfortunately dont have anyone with a lich near by. I would love to see if thats the issue. What would be any red flags with the owl board itself? I feel at this stage though Im out of my depth. Might be worth using befacos service.