Lich Audio In not working

When I calibrate I get a SysEx when I try to save the calibration.

Audio Out’s, gate out, gate in’s etc all work. I was able to test a number of patches and load the latest firmware.

When I test the calibration the Audio In is always 0V.

I believe that I have a problem with my Owl board. I was wondering if any of you could help me confirm:
I loaded the “TestPatch” at: OpenWareLaboratory
Like I mentioned above, when following the procedure laid out in the Test Calibration I always get 0V when I test High and Low.
Since this provides little info, I applied a series of fixed CV voltages to the inputs and the used the “Test High” and “Test Low” buttons and still received 0V output. While I performed these tests I probed throughout the circuit and obtained the following voltages:
First Test:
IN L: 2.5 V (applied and verified with Fluke)
IN R: 5 V (applied and verified with Fluke)
JP4 pin 2 measured at 2.5 V.
JP4 pin 1 measured at 5V.
Vref on the Owl was measured at 2.48 V
Voltage across (Vref, InB) was measured at -.29 V
Voltage across (Vref, InA) was measured at -.59 V

Second Test:
IN L: 9.47 V (applied and verified with Fluke)
IN R: -5 V (applied and verified with Fluke)
JP4 pin 2 measured at 9.47 V.
JP4 pin 1 measured at -5V.
Vref on the Owl was measured at 2.48 V
Voltage across (Vref, InB) was measured at -1.13 V
Voltage across (Vref, InA) was measured at .595 V

The fact that I see different mom-zero voltages reaching the Owl board in these tests, but still measure 0V with the test leads me to believe that my Owl board is defective.

Do you all agree?
Can any of you with working boards repeat the tests above and see if you measure the same/similar voltages but obtain different results with the test?

The firmware versions I have tried are: v22.5.rc2 and v22.4.0

Thanks for any feedback.


…just trying to get feedback on the problem with the Owl board before I raise an issue with Befaco or Rebel Technologies.

I don’t think you have a defective board, because if that would be the case you would get no audio input too. There isn’t anything special going on for V/Oct signal compared to normal audio processing.

There might be some problem with calibration on recent firmware. I think it might be the case that saving settings stopped working after migrating from using internal flash to the larger external SPI flash chip. Could you try an older version like this one: ?

I stand corrected (and feel somewhat embarassed)… thank you!

I had actually not tested an audio through patch. I loaded SilkyVerb and audio did pass through. I then migrated to firmware version 21.2.2 as you suggested. Everything calibrated correctly.

Is there I can do to help correct the calibration issues on the recent firmware? I would like to contribute.

I built my Lich, the first thing you are directed to do after the build is calibrate. It’s not a good look when the first action you take with your newly built HW fails. It invites all kinds of questions about the quality of the build etc.

This particular issue might be not a trivial issue to fix unless you’re familiar with debugging microcontrollers. If you actually are, I can provide some directions where to look into OWL sources.

Well, it sounds like you’ve upgraded firmware instead of calibrating it with original firmware where it was tested :wink: But either way, it’s a major regression and I think I’ve notified @mars a few times that it’s broken in recent firmware versions.

I actually tried calibration with the original firmware (v22.4.0) first. I only attempted different firmware (v22.5.rc2) after calibration failed.

I have experience with SW development. I’d be willing to poke around for a bit and see what I can find. It would be good to get pointed in a rough direction. It looks like you are just using the arm-gcc-none-eabi cross compiler, Makefile and openocd. I already have a compatible environment on my machine, I’ll see about compiling/running the project tonight.

I’ll look into ordering a 5-pin PicoBlade connector and building an adaptor cable to my StLink as well. I just need verify what I have for crimpers etc. when I get home.

Ok, I see that you’re serious about giving it a go and read some relevant docs here.

First of all, there’s a simpler way to connect ST-Link to OWL2 board, I would recommend this because it’s just a bit of soldering to change pins.

Now, the way I would do it is set a breakpoint (in a debug firmware build) around here and see if it gets called and what happens next. This should be called when you try to save calibration settings and I think something no longer works correctly.

Alternatively, you may be able to make a custom release build that uses internal flash that should be usable if my theory is right.

Hey @roabel,

I think I’ve figured out why the recent firmware version were hanging while saving application settings. I didn’t have time to calibrate it, but I expect it to work.

Please try this to see if it works (I have not run it on Lich, but was testing the same code on another hardware)
Lich-flash-fix.syx (333.9 KB)