Lich CV inputs are not full-range?


Having fun with my Lich, though it seems the CV inputs are not full-range.
Testing this Pd drum patch where I input CV into A CV, the trim pot is all the way up.

If I turn the A button, I can select drum sounds just fine. All 5 sounds can be selected.
When I try to do this with CV however, whatever source, it does only select the first two.
It seems like the trim pot is not giving me the full range- or am I misunderstanding how the trim pot of CV A works?

Would love some help!

Well there’s probably at least five different ways to define “full range” in Eurorack, so not sure which one do you mean in this case.

As you can find in the manual, CV inputs accept 0-10V signals. Based on your description, you might be only sending signal up to 5V, which would go just half way.

D’oh! So sorry- for some reason I thought it would adhere to the 0-5v of the MakeNoise Pressure Points, Pamelas New Workout et cetera. So a rectifier in between or some clever patching it is, then! :slight_smile:

I do have this other issue, where when I power my case on, the Lich gets stuck- this happens after a night of not being turned on. It gets stuck and that looks like this:

When I then toggle the power of my case, all is good. Any ideas?

Rectifier won’t make any difference in this case, because the signal is already positive. What you can do:

  • use a linear VCA with that can double your signal (note that some VCA would only lower it)
  • if you want to control patch parameter with CV only, you could set offset knob to 0 and multiply parameter by x2 in your patch to convert half range signal to full range
  • also, I think there is a dedicated module for converting several 5V to 10V signals at takes just 2HP

@mars may have some ideas about the boot problem, but it sounds like about the power supply issue. I recall that old version of OWL board required soldering an extra capacitor to reset pin to solve something similar for a few users. Is there another Eurorack case nearby that you could use to confirm that it hangs during cold boot with another PSU?

Thanks @antisvin.
I went for option #2, multiplying the parameter with x2.

As for the boot problem, I will have a new case coming next week, I will confirm then. Will let you know.

Hi @antisvin- I have another thing I’m running into- I can’t seem to rewrite a slot. I always get an error and end up having to erase all storage to start over again. Any ideas?

Is that happening with every patch slot or just the first one? Also, does it only when you load a particular patch or for every patch? And it’s probably worth it to try a different USB cable in case if it’s faulty.

Only the patch slots which are already taken.
It does it when any patch is selected.
I used three different USB cables.
This is on my macbook running Chrome.
It just gives an “E” for error always when trying to overwrite a slot. No notifications in the web app, it just does not update the patch.

Edit: it has gotten worse! Can’t seem to write any patch now! Was able to erase storage and store one patch. As soon as I connect USB, I get an “E”…

OK, excuse me. I was trying with this patch-
And that was not working- the rest is working… So sorry.

It does not explain, however:

  • The “E” as soon as I connect USB
  • The fact that I have to power my case twice to get it up and running

Faulty patch: it is always good to ‘Load’ a patch to run it from RAM before you store it, to make sure it works.

It is probably trying to load a faulty patch as the default.
Select a patch that works correctly, then press and hold down the encoder a few seconds, until the patch number disappears and appears again. This makes the selected patch the default next time you start up.

Sounds like your power supply does not support the inrush current required by your modules when you switch the system on. It is not an unusual problem in Eurorack. When power is first switched on, current flows in to charge those nice, big decoupling capacitors that every module has to smooth out power supply noise. If this happens too slowly due to limited current, then the voltage will rise slowly up to 12V and some modules might suffer ‘brown-out’ problems.
I would guess that your Lich will at a certain moment receive enough voltage to power on, but then it starts drawing current which contributes to pull the voltage back down below the regulator requirements. In other words, it doesn’t start up cleanly. When you switch it off and on again there’s still enough charge in the decoupling capacitors everywhere in your system that they don’t pull the voltage down, and the Lich can get a clean start.

Sorry, that’s a long explanation! tl;dr: If you want to get rid of this problem then make sure your PSU is strong enough.

@maark, while you’re waiting for the new case, you could try powering only Lich in the old one (other modules disconnected). If you won’t get the same problem on cold boot, it would be a good indication that total power draw is too high when devices start

But he mentioned that it happens when USB is connected, I don’t get how that could be related to loading a bad patch

@antisvin, @mars:
Just now I took out some of the other power-hungry modules in the case and yes, it started up from cold boot immediately! As my new case will have plenty of power, I think this will be solved.

The “E” when I first connect a USB cord is still there, though! Anyway, I can work with this! Yay! Now off to test my chaos/strange attractor CV patch!

Do I output 0-1 from gen for CV? or -1 to 1?

IIRC, it’s 0-1. Not sure why that’s not in the docs yet.

yes the audio outs are DC coupled.

Send -1 to 1 for full scale output on the audio outputs, ie the first two output signals in gen.
To use the CV outs in gen, add another two signal outputs. They will be assigned to CV out 1 and 2. Full scale for these is 0 to 1, as the CV outs are unipolar ie 0 to 10V
There’s a discussion about this here.

Ah yes quite right… hmm… Strange! What OS are you using @maaark? Do you have any MIDI software running which might send messages when a device is connected?

Thanks! I am running Catalina on an old 2012 Macbook Pro Retina.
As far as MIDI software goes- I thought maybe it was because Max was open (as that creates MIDI ports), but that wasn’t it. Otherwise I wouldn’t know. In the holidays I might have time to try with a Windows laptop in my studio.

A friend of mine uses Lich on Mac OS and didn’t mention having any issues with USB. I’ll try to get him to test that patch to see if that would replicate any errors.

And I’ve got confirmation that both issues (error when the USB device is plugged and error when trying to overwrite that patch) can be reproduced on another device. I think this should be considered a good news, as it excludes faulty hardware on @maark’s side. This was tested on MacOS Big Sur.

Thanks @antisvin! I hope you find the reason! For now, I wish you happy holidays!!

I’ve tested with macOS Mojave, v10.14.6, and I get the occasional ‘E’ and ‘Invalid SysEx’ if I keep reconnecting USB, with Chrome open on a patch page. I’ve not dug very deep but it looks as if the OS is sending parts of MIDI messages through when the connection is first made.

It would probably be better to quietly ignore invalid MIDI messages rather than flag them up as errors.

@maark I’ve just found out that there’s something that is intended to overcome the same power issue that you’ve presumably ran into. This device delays module startup, so I guess the problem is common enough for someone to make a commercial solution.

Also, last firmware update should prevent the MIDI errors too.