Witch issues uploading samples and patches

Hi all. Loving this little box but have a few issues and wondering if other folks are finding that it is buggy. The first is I am trying to load in my own samples into the Quad Sampler. I am following the proper format on the site but for some reason I can’t store the sample. It only lets me upload it but the store button stays greyed out after selecting the sample slot.

Second, Installed Granulator patch in slot 8. It works great for about 5-10 secs then the box crashes and just the f light stays on and no function so I have to unplug the USB cable.

Any help would be appreciated since one of the drivers to get this thing was the able to expand it with all the patches.

Thanks.

Hi there,

in the upload form, [Store] is just a label, not a button. Maybe a noun would be better than a verb… [Position] ?
So clicking e.g. [Sample 1] should be enough. We need to add a progress bar to the page, at the moment it is a bit beyond my JS skillz. So instead, keep an eye on the Witch: as the sample is uploaded the top LEDs light up to show progress.

If there’s a problem with the upload, it should be indicated with an error message at the top of the web screen.

Granulator, you mean this patch?

That seems to be pushing the device over 100% CPU. I’ve now recompiled it and it runs within spec, so pls try it again. If there are any other patches that misbehave let us know!

Side note: At the moment, when a patch goes over 100% CPU it causes the firmware to reset into bootloader. This is not super helpful in itself, but we need to protect against situations where a rouge patch renders the device unresponsive. Probably a better way to deal with it would be to first try to reset the patch itself. To do this we’d probably have to run a timer on an interrupt when a patch is started which kicks in before device reset. Something to think about for a future firmware version.

Thanks for the reply. Once you fixed the Granulator it is working now and super nice patch. Once I changed the samples to mono they worked fine but not the stereo.

@I.O.M Are your stereo files less than 1Mb in size?

When you go to witch.rebeltech.org it should give you the firmware version in the top right corner. Can you pls verify you’ve got v22.0.0?