Owl-Modular stuck

i’m a bit nervous since it’s first time to write a question here, but my OWL-modular stop to communicate with me… so it would be great if you could help me.
(also sorry for my poor English skill)

i could use OWL-modular with openware v20.3 for a while. but after I uploaded simple gen patch onto slot 1 from the website, it starts only to make pulse noise and LED blink, and can not be recognized from anymore. OWL-MIDI never appear on the device manager.

it still can be booted as bootloader mode by starting-up with holding push button, then it appears as STM32 BOOTLOADER. and it’s possible to send firmware (20.3) from OwlNest (OpenWareLaboratory doesn’t detect it). I tried to resend the firmware a couple of times, but the situation doesn’t change.

it seems similar problem reported here ? Wizard not working after device reset command

maybe what I should do is delete uploaded patch on slot 1 ? but i can’t find how to do it. maybe newer version of OpenWare already solve this problem ? but not for Owl-Modular ?

thanks for your help in advance.

It looks like you will have to format patch storage, I think this is the first thing to do in such cases. There are a few things that can be done to fix this:

  1. Install newer firmware - maybe this error was fixed and it can finish booting even with a broken patch

  2. Install MIDI bootloader and use it to delete patch storage - this would erase broken patch and then your firmware would not get error on boot.

  3. Use ST-Link programmer to delete patch storage from flash.

I can make an unofficial build for newer firmware that I’ve used for myself before (not the latest, but at least from this year). It’s probably a good idea to try that to see if firmware update can solve this or not before trying anything else.

As for MIDI bootloader, it would require using ST-Link v2.1 programmer to update device flash chip. This bootloader can accept different commands using MIDI - including deleting patch storage. There are no official builds, but I can upload one if necessary.

As you see, if simply updating firmware wouldn’t help, you’ll need ST-Link. We should probably wait for Martin from Rebel Technology to visit this topic, maybe he’ll have better ideas how this can be solved.

Found last firmware build that I’ve tested on my Owl. I think this is firmware v20.9 + custom code that allows switching patches after pressing button like on old firmware. Extension is .pdf because forum doesn’t let me use .bin for uploads.

OwlPedal.bin.pdf (241.4 KB)

1 Like

Thank you so much !!! very much encouraging to hear your help !
I upgrade to new firmware you uploaded. OwlNest send .bin file without problem, however, unfortunately the condition of OWL doesn’t change…
probably I should use MIDI bootloader ? i’ll get ST-Link programmer anyway.

Yes, you would probably have to get an st-link.

It’s not necessary to get an official one from ST-Microelectronics, because you can use much cheaper Chinese clone. Their price on Amazon starts from 250 yen or so. I think that any version ST-link would be ok here, the Chinese ones look like this: https://images-na.ssl-images-amazon.com/images/I/51%2BQAM4GgQL.AC_SL1001.jpg (their cases can come in different colors, doesn’t matter which one you’re getting)

Besides ST-link, you will need to use program called “openocd” that is used to connect to microcontroller using programmer. We have some information on forum, but specific instructions depend on which OS you use.

Hi @hibarimusic, welcome!

Yes this sounds like a ‘reset-loop’: the default patch for some reason causes the firmware to reset, repeating over and over.

With the bootloader that you have, it should be possible to delete the patches using a DFU utility, e.g. dfu-util. Or one of the tools that ST make available.

What OS are you using? If you’re on Mac OS X, you could try installing dfu-util with brew install dfu-util. Otherwise let us know and we’ll work out some alternative instructions!

There’s also this, which looks intriguing, but I’ve never tried it:

Maybe it could replace the old OwlNest completely.

This is the ST tool I was referring to:

It should be capable of operating with both SWD (ie with a hardware programmer attached) and DFU (using the legacy OWL bootloader). And it’s cross-platform.

The procedure to fix the reset loop would be:

  • Connect OWL in bootloader mode
  • Start STM32CubeProgrammer and select USB protocol (blue drop-down next to Connect)
  • Erase sectors 8, 9 and 10 (see section 2.3 of the manual)

Daisy devs rely on that web DFU script too. And I think there are a few versions made for other vendors. So software itself is usable (in Chromium based browsers). It’s not entirely issue-free, i.e. some Mac users had permission errors and last Windows update broke it at least in some cases.

So not sure about replacement, but it could be a user-friendly alternative.

Thank you !! very much helpful !
i forgot to mention, i use Windows 10, 64bit. i’m going to try dfu-util, and keep reporting here.

Hello again,
dfu-util didn’t run on my computer.
WebUSB DFU could connect to STM32 bootloader, but i don’t know what to do…
so, I tried STM32CubeProgrammer, and it seems working in the first place.no problem to connect through USB, and i erased sector 8,9 and 10 (as attached screenshot).
but after rebooting, OWL acts as same as before…looping reset.
did i miss something ?
sorry for bothering you, and thank you for your support !

Okay cool, great work!

There was an error in my instructions, and you need to erase sector 11 also.

Sorry about that. On the OWL firmware, the patches are stored from the last sector, in reverse order down to sector 7. So it means that patch 1 will be on sector 11.

I thought that OpenWare was used in this case (based on v20.3 mentioned above). Then the extra sector that needs erasing is 7. Deleting 11 won’t hurt too in case if there’s anything in there, but won’t help with the bad patch issue.

1 Like

oh wow !!!
amazing !
i erased sectors from 7 to 11, then OWL fly back to me. the device is detected properly from the web.
thank you so much !!! it helps me wonderfully !


right you are @antisvin, thank you :slight_smile:

@hibarimusic, the firmware build that I’ve uploaded has some bugfixes specifically for Owl. They were added after the old 20.3 release that was the last official build. It’s probably better to use it instead of 20.3 and I was planning to make some new builds with more recent features.

And of course you will be able to switch patches from the device itself. I’ve ported that code from the old OwlWare firmware. Just press button, wait for a few seconds when LED starts changing colors and move first two knobs to select patch, then unpress button. LED would change color when different patch index is selected.

As for MIDI bootloader, it would allow you to install firmware updates and do some other operations without DFU program (from Chrome browser or by sending MIDI commands directly). It’s not mandatory to use it with the new firmware, but it makes some things easier. If you want to try it, let me know when you have the programmer and I can upload bootloader image.

I think most people don’t change firmware to OpenWare, that’s why we don’t have clear instructions ready yet. But it works better than the old one if you have the time and patience to update Owl.

hello, thanks again for your suggestions.
it would be great if i could use the firmware you’ve uploaded… but Chrome browser can’t detect OWL with this version (it’s pity since it seems OWL itself works OK…). it’s no problem with v20.3, so i get back there for a moment.
i guess it will be much easier with programmer. i’ll let you know when i get one.
anyhow it’s exciting to explore these world… thanks again.

That’s strange, because I thought that this firmware would still be using the same code for MIDI interface. We have newer USB code that would make it possible to use it Owl as an USB audio interface. But I think it wasn’t used here yet.

Hello, I’ve been great with Owl-modular and Magus in these days. however, now Magus only blinks all LED after i try to load a patch from web. it seems like “reset-loop” problem again now on Magus ?

i think latest firmware is on it. so it’s not as easy as pressing button like OWL-modular to boot Magus in bootloader mode ?? any suggestion would be helpful, thank you in advance !

申し訳ございません! Does that happen only when you try to load patches or immediately when device is powered?

Also, is it running the original bootloader code or did you update it?

Unfortunately there’s no way to force bootloader mode on Magus with a simple pin press. It has to be done with a MIDI command. Encoders and CV inputs don’t connect to microcontroller directly and require more complex code, so they’re not usable in bootloader.

If you can’t get to bootloader mode, you’ll probably have to resolve this with ST-Link programmer. It may also be possible to solve this if you can find another Rebeltech device that uses OWL2 board and can be forced into bootloader mode (so not OWL1 pedal/modular and not Magus).